Sediment Budget Analysis System (SBAS) for ArcGIS 10

User’s Guide
Contents

Introduction .................................................................................................................................... 5
SBAS Versions .................................................................................................................................. 5
About SBAS for ArcGIS 10 ............................................................................................................ 5
Requirements .................................................................................................................................. 6
Definitions ....................................................................................................................................... 6
Installing the SBAS Toolbar ............................................................................................................ 7
About the SBAS Toolbar .................................................................................................................. 9
Docking the SBAS Toolbar 9
Undocking (“Floating”) the SBAS Toolbar 9
Displaying the SBAS Toolbar 9
Understanding the SBAS Toolbar 9
Using the SBAS Toolbar with ArcMap .......................................................................................... 10
Creating Sediment Budgets—Overview ....................................................................................... 11
Setting up the Data in ArcMap ..................................................................................................... 12
Setting the SBAS Default Properties ............................................................................................... 12
Creating Littoral Cells ...................................................................................................................... 13
Draw Rectangular Cells 14
Draw Irregularly Shaped Cells 15
Creating an Alternative and a Littoral Cell Layer ......................................................................... 16
Editing the Cells in a Littoral Cell Layer .......................................................................................... 19
Add a Cell to a Littoral Cell Layer 19
Resize, Reshape, and Move a Littoral Cell in a Littoral Cell Layer 21
Remove a Cell from a Littoral Cell Layer 21
Set the Cell Color and Label Options in a Littoral Cell Layer 23
Creating Flux Lines ......................................................................................................................... 24
Draw Straight Flux Lines 25
Draw “Curved” Flux Lines (Polylines) 26
Creating a Flux Layer and Adding it to an Existing Alternative .................................................. 28
Editing the Flux Lines in the Flux Layer .......................................................................................... 30
Add Flux Lines to a Flux Layer 30
Resize, Reshape, and Move a Flux Line in a Flux Layer 32
Remove a Flux Line from a Flux Layer 33
Entering Littoral Cell and Flux Line Values ...................................................................................... 34
Enter Littoral Cell Values 34
Entering Flux Line Values 35
Identifying Littoral Cell Layer Confidence ................................................................. 36
Creating a Macro Budget ......................................................................................... 37
Saving an Alternative............................................................................................. 41
Saving a New Alternative ....................................................................................... 41
Copying an Alternative .......................................................................................... 42
Opening an Existing Alternative ............................................................................ 42
Loading an SBAS Layer ........................................................................................ 43
Using SBAS Standalone Files in SBAS for ArcGIS 10 .......................................... 44
Using SBAS Toolbar Files in SBAS Standalone ..................................................... 47
Introduction

A sediment budget is a measure of sediment (usually sand) “sources” (inputs), “sinks” (outputs), and net change within a specified “control volume” (a cell or series of connecting cells) over a given period of time. It is a fundamental planning and design tool for projects concerned with sediment transport, deposition, and erosion.

SBAS (Sediment Budget Analysis System) for ArcGIS 10 provides a framework for formulating, documenting, and calculating sediment budgets, including estimation of uncertainty. This Windows application allows users to define a conceptual budget visually by creating a series of cells and arrows that represent sources, sinks, and flux rates. It then calculates quantitative “micro” (local) and “macro” (regional) sediment budgets, using a pre-defined sediment-budget equation.

SBAS Versions

Two versions of SBAS (are available:

- **SBAS for ArcGIS 10**—A custom toolbar designed for use with ArcGIS/ArcMap 10 in order to provide sediment budget capability within a Geographic Information System (GIS) database. (Earlier versions of this toolbar were referred to as “SBAS-A.”)

- **SBAS Standalone**—A standalone version of the application, which allows non-georeferenced images to be used as a background for local (“zoom-in”) and regional (“zoom-out”) sediment budgets. This application can be used only with ArcGIS/ArcMap 9.3

Files created in SBAS Standalone can be brought into SBAS for ArcGIS 10 (refer to “Using SBAS Standalone Files in SBAS for ArcGIS 10” on page 44), and SBAS for ArcGIS 10 files can be used in SBAS Standalone (refer to “Using SBAS Toolbar Files in SBAS Standalone” on page 47).

About SBAS for ArcGIS 10

SBAS for ArcGIS 10, the subject of this manual, is designed for users who have access to existing geospatial datasets to assist them in building sediment budgets. These datasets include such items as georeferenced aerial photography, beach profile surveys, shoreline position data, dredging history, coastal process, and bathymetry surveys. Provided that they are in a format ArcMap can translate (for example, .tif, .sid, .shp, or .lyr), all pertinent information can be added to the data frame for analysis. The data can be viewed spatially in the data frame, and its attributes can be viewed in the associated database file.
Requirements

- **ArcGIS/ArcMap 10**—SBAS for ArcGIS 10 is designed to run with Esri’s ArcGIS/ArcMap 10.

- **Microsoft .NET 4 Framework**—.NET 4 is required to run the SBAS_Arc10_Tools.esriAddIn file, which installs the SBAS Toolbar in ArcMap 10.

- **SBAS Standalone**—If the SBAS Standalone version is not already installed on your workstation, install it before installing and using the SBAS Toolbar—it is required because it contains the “black box” files that perform all of the SBAS calculations. (This requirement may be removed in a future SBAS Toolbar release.) SBAS Standalone is available at [http://cirp.usace.army.mil/products/](http://cirp.usace.army.mil/products/): Click the SBAS tab, click SBAS Standalone PC Program, click SBAS Standalone Executable, and then click Run.

Definitions

- **Alternative**—A representation of one set of assumed conditions for a sediment budget. Each alternative has its own set of fluxes, cells, placements (inputs), and removals (outputs). Alternatives may be created to reflect different assumptions about sediment-transport rates and paths, and engineering activities within a budget, or they may reflect different time periods. At least one alternative must be created in an SBAS session. Alternatives save all values applied to cells and fluxes.

- **Attribute Table**—A table used to store attribute information for a specific coverage feature class (for example, littoral cell, flux, and confidence layers). Each row represents a feature, and each column denotes a field. To view a layer’s attribute table, in the ArcMap Table of Contents right-click the layer and from the pop-up menu select Open Attribute Table.

- **Confidence**—The certainty level that the values assigned to littoral cells and fluxes are accurate.

- **Feature**—A point, line, or polygon in a coverage, shapefile, or geodatabase feature class.

- **Flux**—Representation of the input and output of sediment into a littoral cell. Each cell requires both eastward and westward transport rates.

- **Layer**—A collection of similar geographic features (such as rivers, lakes, littoral cells, and fluxes) in a particular area or place referenced together for display on a map. A layer references geographic data stored in a data source, such as a shapefile, and defines how to display it.

- **Littoral Cell**—A collection of information describing similar physical, biological, and cultural characteristics within a particular area along a river, lake, sea, or ocean.

- **Macro Budget**—A sediment budget for a region; it may consist of multiple micro budgets.
Micro Budget—A sediment budget for a specific local area.

Sediment Budget—A measure of sediment (usually sand) “sources” (inputs), “sinks” (outputs), and net change within a specified “control volume” (a cell or series of connecting cells) over a given period of time.

Shapefile—A vector data storage format for storing the shape, location, and attributes of geographic features. A shapefile is stored in a set of related files and contains one feature class.

Sink—The destination of sediment that is moved from its original location.

Source—The point of origin of sediment that is moved to a different location.

Table of Contents—In ArcMap, a list of all the data frames and layers on the map, showing what features the symbols in each layer represent.

Working Directory—The default location where all files created during an SBAS session are stored.

Installing the SBAS Toolbar

Before you install the SBAS Toolbar, the SBAS Standalone version must be installed on your workstation because it contains the “black box” files that perform all of the SBAS calculations. If SBAS Standalone is not already installed, use the following steps to install it.

Note: You must have administrator privileges to perform this procedure.

2. Click the SBAS tab.
3. Click SBAS Standalone PC Program.
4. Click SBAS Standalone Executable.
5. In the File Download message box, click Run.

Now use the following steps to install the SBAS Toolbar:

1. Download the SBAS Toolbar application files.
   b. Click the SBAS tab.
c. Click SBAS Addin for ArcGIS 10.

d. Click SBAS Extension.

e. In the File Download message box, click Save.

f. In the Save As dialog box, locate the appropriate folder on your workstation, and then click Save.

2. Unzip the file you downloaded in the previous step.

3. Double-click the SBAS_Arc10_Tools.esriAddIn file.

   An Esri ArcGIS Add-In Installation Utility dialog displays.

4. Click Install Add-in.

   A message box displays, stating “Installation succeeded.”

5. Click OK.

6. Open ArcMap.

7. From the Customize menu, select Add-In Manager.

   An Add-In Manager dialog displays. SBAS_Arc10_Tools should be listed in the My Add-Ins section on the Add-Ins tab.

8. Click Customize.

   A Customize dialog displays.

9. If necessary, click the Toolbars tab.

10. Select (check) the SBAS Toolbar check box.

11. Click Close.

   The SBAS toolbar displays on the screen.
About the SBAS Toolbar

By default, the SBAS Toolbar “floats” on the screen—that is, rather than being “fixed” to the top or side of the screen, it is positioned somewhere on the screen and easily be dragged to other locations on the screen.

Docking the SBAS Toolbar

To “dock” the SBAS Toolbar (that is, to “fix” it to the top, bottom, or side of the screen), drag and drop it onto any existing toolbar or drag it to the edge of the screen.

Undocking (“Floating”) the SBAS Toolbar

If the SBAS Toolbar is docked and you want to undock (or “float”) it, position the cursor on the left edge of the docked toolbar (the cursor changes to a four-way arrow), and then drag and drop the toolbar onto the data frame.

Displaying the SBAS Toolbar

If, at any time, the SBAS Toolbar isn’t displayed, from the ArcMap Customize menu select Toolbars>SBAS Toolbar.

Understanding the SBAS Toolbar

The SBAS Toolbar provides the following menus and commands.

<table>
<thead>
<tr>
<th>Menu/Command/Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alternative Menu</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="New Alternative" /></td>
<td>Creates a new alternative.</td>
</tr>
<tr>
<td><img src="image" alt="Load Project Alternative" /></td>
<td>Saves the current alternative file (.sbd) and loads a new alternative file. <strong>Note:</strong> This function is still in development. <strong>Note:</strong> Before editing an existing sediment budget, you must load the alternative file associated with its shapefiles.</td>
</tr>
</tbody>
</table>
**Menu/Command/Button** | **Function**
---|---
Copy Alternative | Saves a copy of the current alternative.

*Note:* The attribute table of each layer marked with the instance of the selected alternative is automatically updated with the name and path of the associated alternative file.

Save Project Alternative | Saves both the ArcMap file (.mxd) and the appropriate alternative file (.sbd).

Set Preferences | Customizes the working directory, measurement units, and uncertainty method.

**Budgets Menu**

Load SBAS Layer | Loads an SBAS layer and its associated alternative file.

Convert Graphics to SBAS Layer | Converts graphics in the data frame into littoral cell or flux layers.

Add Graphics to Existing Layer | Adds littoral cells or flux lines to the selected layer.

**Edit Menu**

Set Confidence | Identifies your degree of certainty that the recorded littoral cell and flux values are correct (for example, High, Medium, Low, No Data).

Show Confidence | Using the layer symbology, displays on the map the confidence level assigned to each littoral cell.

*Note:* The cells are outlined in confidence level colors.

Remove Cells/Fluxes | Deletes littoral cells or flux lines from the active layer in the Table of Contents and the alternative.

Edit Cell/Flux Values | Allows you to edit cell or flux values in the selected layer.

**Using the SBAS Toolbar with ArcMap**

For each littoral cell, flux line, and macro budget, SBAS produces a shapefile with the following field attributes.

*Note:* SBAS automatically generates these attributes; in order for SBAS to calculate the residual for the sediment budget properly, all values must be edited using the SBAS Toolbar.
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Applicable to</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT_ID</td>
<td>✓</td>
<td>String</td>
<td>ID assigned to the alternative</td>
</tr>
<tr>
<td>ALT_NAME</td>
<td>✓</td>
<td>String</td>
<td>Name of the alternative associated with the feature</td>
</tr>
<tr>
<td>CONFIDENCE</td>
<td>✓</td>
<td>String</td>
<td>Uncertainly level (High, Medium, Low, No Data) assigned to the data</td>
</tr>
<tr>
<td>DV</td>
<td>✓</td>
<td>Numeric</td>
<td>Net change in volume within the cell or macro budget</td>
</tr>
<tr>
<td>END_DATE</td>
<td>✓</td>
<td>Date</td>
<td>The end date of the time period when showing change over time in an ArcMap time-enabled layer</td>
</tr>
<tr>
<td>ID</td>
<td>✓</td>
<td>String</td>
<td>ID assigned to the feature</td>
</tr>
<tr>
<td>NAME</td>
<td>✓</td>
<td>String</td>
<td>Name of the feature; automatically generated, using the feature layer name and the record number</td>
</tr>
<tr>
<td>PLACEMENT</td>
<td>✓</td>
<td>Numeric</td>
<td>Placement volume</td>
</tr>
<tr>
<td>QVALUE</td>
<td>✓</td>
<td>Numeric</td>
<td>Sources and sinks to the control volume</td>
</tr>
<tr>
<td>REMOVAL</td>
<td>✓</td>
<td>Numeric</td>
<td>Removal volume</td>
</tr>
<tr>
<td>RESIDUAL</td>
<td>✓</td>
<td>Numeric</td>
<td>Representation of the degree to which the cell is balanced</td>
</tr>
<tr>
<td>SBAS_FILE</td>
<td>✓</td>
<td>String</td>
<td>Path and file name of the alternative related to the feature</td>
</tr>
<tr>
<td>START_DATE</td>
<td>✓</td>
<td>Date</td>
<td>The start date of the time period when showing change over time in an ArcMap time-enabled layer</td>
</tr>
</tbody>
</table>

Creating Sediment Budgets—Overview

The basic procedure for creating micro and macro sediment budgets consists of the following steps. Each is described in detail in the following sections.

1. Set up the data in ArcMap.
2. Set the SBAS default properties.
3. Create the littoral cells.
4. Create an alternative and littoral cell layer.
5. Edit the cells in the littoral cell layer, if necessary.
6. Create the flux lines.
7. Create a flux layer and add it to an existing alternative.
8. Edit the flux line in the flux layer, if necessary.
9. Enter the littoral cell and flux line values.
10. Identify the littoral cell layer confidence.
11. Create the macro budget.

### Setting up the Data in ArcMap

Before using the SBAS Toolbar to develop a sediment budget, use the following procedure to set up data in ArcMap.

1. If you have not done so already, open ArcMap.
2. Use the ArcMap (Add Data) tool to add into the data frame the appropriate datasets to assist you in the analysis and design of the sediment budget.

   You can add vector, raster, and tabular data.

### Setting the SBAS Default Properties

Once the initial base map data has been added into the data frame, use the following procedure to set the SBAS default properties, which determine some of the basic elements of the sediment budget.

1. In the SBAS Toolbar, select Alternative>Set Preferences.

   The Set Preferences dialog displays.
2. Change the following default properties, as necessary.

**Note:** These preferences can be changed at any point during an SBAS session.

- **Working Directory**—The default location where all SBAS alternatives and layers/shapefiles are stored.
  
  **Note:** Layers are given the projected coordinate system selected in the ArcMap View>Data Frame Properties menu, Coordinate System tab.

- **Measurement Units**—The units of measurement used for all SBAS calculations.
  Choices include Cubic Meters, Cubic Meters per Year, Cubic Yards, and Cubic Yards per Year.

- **Uncertainty Method**—The uncertainty method used for SBAS.
  Choices include Maximum and Root Mean Square.

3. Click Apply.

### Creating Littoral Cells

Littoral cells are defined by a collection of information describing similar physical, biological, and cultural characteristics within a particular area. Littoral cell data can be in the form of a map, database, or text.

The boundaries of the littoral cells can be defined either by morphological features (such as ebb and flood shoals, inlet throat, and adjacent beaches) or by political features (such as nautical charts and municipal boundaries).

Use the following procedures to draw one or more littoral cells in the ArcMap data frame.

**Note:** While these examples use the Rectangle and Polygon tools to create littoral cells, you can also use the circle and ellipse tools.

**Note:** If you need to add more cells at a later point, you can do so with the SBAS Add Graphics to Existing Layer command. (Refer to “Add a Cell to a Littoral Cell Layer” on page 19 for more information.)
**Draw Rectangular Cells**

1. In the ArcMap Draw toolbar, click the □ (Rectangle) tool.

   **Note:** If the Draw toolbar isn't displayed, from the Customize menu select Toolbars>Draw. If the □ (Rectangle) tool isn't displayed, click the▼ button to the right of the selected shape tool and then, from the pop-up menu, select □ (Rectangle).

2. In the data frame, position the cursor in the upper-left corner of the new cell, press and hold down the mouse button, and drag the rectangle to the lower-right corner.

3. Release the mouse button.

   A rectangular cell displays in the data frame.

4. Click anywhere in the data frame to unselect the graphic.
**Draw Irregularly Shaped Cells**

1. In the ArcMap Draw toolbar, click the_polygon_(Polygon)_tool.

   **Note:** If the Draw toolbar isn't displayed, from the Customize menu select Toolbars>Draw. If the_polygon_(Polygon)_tool isn't displayed, click the button to the right of the selected shape tool and then, from the pop-up menu, click_polygon_Polygon_.

2. In the data frame, click each of the new cell’s vertices (corners) except the last one.

3. Double-click the new cell’s last vertex (corner).

   A polygon displays in the data frame.

4. Click anywhere in the data frame to unselect the graphic.
Creating an Alternative and a Littoral Cell Layer

Use the following procedure to create an alternative and littoral cell layer from one or more cells.

1. Select the graphic(s) you just created.

   All of the cell graphics in the data frame are selected.

2. In the SBAS Toolbar, select Budgets>Convert Graphics to SBAS Layer.

   An Enter Alternative Name dialog displays.

3. Enter the name of the new alternative.

   Note: An alternative saves all values associated with the sediment budget. Each alternative should consist of only a single littoral cell layer and a single flux layer.
4. Click OK.

A Convert Graphics to SBAS Layer dialog displays. The Select Alternative drop-down list box is automatically populated with the alternative name you entered in the previous step, and Micro is automatically selected as the Budget Layer Type.

5. If it isn't already selected, in the Graphic Conversion Options section, select the Selected Graphics radio button.

**Note:** Selecting the All Graphics radio button will delete *all graphics* not in layers/shapefiles (for example, arrows, labels, and other text), *not only* the graphics you just created and selected.

6. If it isn't already selected, in the Graphic Conversion Options section, select Delete All Graphics in View after Conversion.

**Note:** This option automatically deletes the graphic(s) you drew, leaving only the littoral cells.

7. To the right of the New Layer Name text box, click Browse.

A Select New Layer Folder and Name dialog displays.

8. Browse to the appropriate directory.

9. In the File Name text box, type a name for the new layer.

10. Click Save.

The Convert Graphics to SBAS Layer dialog redisplays, and the New Layer Name field is populated with your selection.

11. Click Create New Layer.

All graphics are converted into a littoral cell layer, the new layer is added to the ArcMap Table of Contents, symbology is applied to the layer, the layer is stored in the SBAS working directory, and a Save Alternative dialog displays. (See “Setting the SBAS Default Properties” on page 12.)

12. In the Select Alternative to Save drop-down list box, select the alternative you identified in step 3.

13. In the File Path/Name text box, enter the full path and file name of the alternative, or click Browse, browse to the appropriate directory, enter a file name, and click Save.
14. Click Save Alternative.

The data frame redisplays.

By default, when a littoral cell is created, all residual values are set to 0. Therefore, all cell colors remain uniform until cell or flux values are edited.
Editing the Cells in a Littoral Cell Layer

Add a Cell to a Littoral Cell Layer

Use the following procedure to add one or more additional cells to an existing littoral cell layer.

1. In the ArcMap Draw toolbar, use the \( \text{(Rectangle)} \) and/or \( \text{(Polygon)} \) tool to add one or more littoral cells in the ArcMap data frame.

   **Note:** Refer to “Creating Littoral Cells” on page 13 for more information.

2. Click anywhere in the data frame to unselect the graphic.

3. Select the graphic(s) you just created.

   All of the new cell graphics in the data frame are selected.
4. In the SBAS Toolbar, select Budgets>Add Graphics to Existing Layer.

   An Add Graphics to Layer dialog displays.

5. From the Select Layer to Edit drop-down list box, select the layer to which you want to add the cells.

6. If it isn’t already selected, in the Graphic Conversion Options section, select the Selected Graphics radio button.

   **Note:** Selecting the All Graphics radio button will delete all graphics not in layers/shapefiles (for example, arrows, labels, and other text), not only the graphics you just created and selected.

7. If it isn’t already selected, select (check) the Delete All Graphics after Conversion check box.

8. Click Add to Cell Layer.

   The selected graphic(s) are added to the specified layer, and the data frame redisplay.
**Resize, Reshape, and Move a Littoral Cell in a Littoral Cell Layer**

Use the following procedure to resize, reshape, or move a cell in a littoral cell layer.

1. From the ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
   
   A Start Editing dialog displays.

2. Select the littoral cell layer from the list.

3. Click OK.
   
   The Create Features panel displays on the screen.

4. In the ArcMap Editor toolbar, click (Edit Tool).

5. Select the littoral cell you want to edit.

6. Use the tools in the ArcMap Editor toolbar to resize, reshape, and/or move the cell as necessary.
   
   Refer to the ArcMap 10 documentation for details.

7. From the ArcMap Editor toolbar, select Editor>Stop Editing.

8. When prompted to save your changes, click Yes.
   
   Your changes are saved, the cell is unselected, and the Create Features pane closes.

**Remove a Cell from a Littoral Cell Layer**

Use the following procedure to remove one or more littoral cells from a littoral cell layer.

1. In the ArcMap Table of Contents, select the littoral cell layer.

2. From the ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
   
   A Start Editing dialog displays.

3. Select the littoral cell layer in the list.

4. Click OK.
   
   A Create Features panel displays.
5. Select the cell(s) you want to delete.

   **Note:** To select multiple cells, click the first one and then, while holding down the Shift key, click each additional cell.

6. In the SBAS Toolbar, select Edit>Remove Cells/Fluxes.

   **Note:** Currently, the confirmation box lists only the first cell selected. The development team is working on this issue.

   **Note:** It is imperative that you use the SBAS Edit>Remove Cells/Fluxes command to remove cells, not the ArcMap Edit>Delete command. The SBAS command removes both the selected cells and their related values while the ArcMap command deletes only the cell, which will result in an incorrect sediment budget calculation.

7. Click Yes.

   The selected cell(s) are removed from the littoral cell layer, and the editing session automatically closes.

8. If you've already saved the alternative in this ArcMap session, this procedure ends here.

   However, if you haven't yet saved the alternative in this ArcMap session and are prompted to save the alternative, click OK.

   A Save Alternative dialog displays, prepopulated with the Alternative name and full path and file name.

9. Click Save Alternative.

   An Overwrite message box displays.

10. Click Yes.

    A Saved message box displays.

11. Click OK.

    The data frame redisplay.
Set the Cell Color and Label Options in a Littoral Cell Layer

By default, all littoral cells are 75% transparent, so any data beneath the cells can be seen. However, cell transparency—as well as label font, size, and color—can be changed by editing the littoral cell layer’s properties.

**Note**: Cells that are set to 100% transparent still exist and can be selected during an editing session; they just don’t display (except for the cell label) in the data panel.

1. In the ArcMap Table of Contents, right-click the layer name and, from the pop-up menu, select Properties.
   
   A Layer Properties dialog displays.

2. Click the Display tab.

3. In the Transparent text box, type a number indicating the transparency percentage.

4. Click the Labels tab.

5. If it isn’t already selected, select (check) the Label Features in this Layer check box.

6. In the Text Symbol section, select the label font, size, and color.
7. Click OK.

The map redisplayed with your cell color and label choices. The following illustration shows cell transparency set to 90% and label properties set to Arial, 8 pt, blue.

Creating Flux Lines

Flux lines represent the flow of sediment into and out of littoral cells. Using the ArcMap Draw toolbar, you draw flux lines on the map to identify the direction of flow. Afterwards, you assign sediment transport values to these flux lines. Each sediment budget cell requires both eastward and westward transport rates.

Use the following procedures to draw one or more flux lines in the ArcMap data frame.

**Note:** While these examples use the (Line) tool to create straight and “curved” (polyline) flux lines, you can also use the curve and freehand tools to create flux lines.

**Note:** If you need to add more flux lines at a later point, you can do so with the SBAS Budgets>Add Graphics to Existing Layer command. (Refer to “Add Flux Lines to a Flux Layer” on page 30 for more information.)
**Draw Straight Flux Lines**

*Note:* While each cell requires both eastward and westward transport rates, this example demonstrates drawing only a single straight flux line.

1. In the ArcMap Draw toolbar, click the (Line) tool.

   *Note:* If the Draw toolbar isn't displayed, from the Customize menu select Toolbars>Draw. If the (Line) tool isn't displayed, click the button to the right of the selected shape tool and then, from the pop-up menu, click Line.

2. In the data frame, click the source cell.

3. Double-click the sink cell.

   The two cells are connected by the line.

   *Note:* The arrowheads of the flux lines do not display initially; they are not symbolized until the line graphics are converted into a flux layer.

4. Click anywhere in the data frame to unselect the line.
Draw “Curved” Flux Lines (Polylines)

Polylines allow a line to have multiple vertices, so it can to “curve” around structures.

**Note**: While each cell requires both eastward and westward transport rates, this example demonstrates drawing only a single polyline.

1. In the ArcMap Draw toolbar, click the \( \text{Line} \) tool.

   **Note**: If the Draw toolbar isn't displayed, from the Customize menu select Toolbars>Draw. If the \( \text{Line} \) tool isn't displayed, click the button to the right of the selected shape tool and then, from the pop-up menu, click \( \text{Line} \) .

2. In the data frame, click the source cell.

3. In the data frame, click each of the polyline's vertices except the last one.
4. Double-click the polyline’s last vertex on the sink cell.

The two cells are connected by the polyline.

**Note:** The arrowheads of the flux polylines do not display. They are not symbolized until the polyline graphics are converted into a flux layer.

5. Click anywhere in the data frame to unselect the line.
Creating a Flux Layer and Adding it to an Existing Alternative

Use the following procedure to create a flux layer from one or more graphics and add it to an existing alternative.

1. Select the line(s) you just created.

All lines in the data frame are selected.

2. In the SBAS Toolbar, select Budgets>Convert Graphics to SBAS Layer.

A Convert Graphics to SBAS Layer dialog displays. Micro is automatically selected as the Budget Layer Type.

3. From the Select Alternative drop-down list box, select the appropriate alternative (that is, the one containing the littoral cell layer you created earlier).
4. If it isn’t already selected, in the Graphic Conversion Options section, select the Selected Graphics radio button.

**Note:** Selecting the All Graphics radio button will delete *all graphics* not in layers/shapefiles (for example, arrows, labels, and other text), *not only* the graphics you just created and selected.

5. If it isn’t already selected, in the Graphic Conversion Options section, select (check) the Delete All Graphics in View after Conversion check box.

6. To the right of the New Layer Name text box, click Browse.

A Select New Layer Folder and Name dialog displays.

7. Browse to the appropriate directory.

8. In the File Name text box, type a name for the new layer.

9. Click Save.

The Convert Graphics to SBAS Layer dialog redisplay.

10. Click Create New Layer.

All graphics are converted into a flux layer, the new layer is added to the ArcMap Table of Contents, symbology is applied to the layer, the lines are transformed into arrows (with the arrow tail indicating the source cell and the arrow head indicating the sink cell), and the layer is stored in the SBAS working directory, and the data frame redisplay. (See “Setting the SBAS Default Properties” on page 12.)

**Note:** Because Delete All Graphics After Addition was selected in the Add Graphics to Layer dialog, the graphic(s) you drew were automatically deleted.
Editing the Flux Lines in the Flux Layer

Add Flux Lines to a Flux Layer

Use the following procedure to add one or more additional flux lines to a flux layer.

1. In the ArcMap Draw toolbar, use the tool to add one or more lines and/or polylines in the ArcMap data frame.

   Note: Refer to “Creating Flux Lines” on page 24 for more information.

2. Select the graphic(s) you just created.

   All of the line graphics in the data frame are selected.
3. In the SBAS Toolbar, select Budgets>Add Graphics to Existing Layer.

   An Add Graphics to Layer dialog displays.

4. From the Select Layer to Edit drop-down list box, select the layer to which you want to add the lines.

5. If it is not already selected, in the Graphic Conversion Options section, select the Selected Graphics radio button.

   **Note:** Selecting the All Graphics radio button will delete *all graphics* not in layers/shapefiles (for example, arrows, labels, and other text), *not only* the graphics you just created and selected.

6. If it is not already selected, select (check) the Delete All Graphics after Conversion check box.
7. Click Add to Flux Layer.

The selected graphic(s) are added to the specified layer, and the data frame redisplays.

**Note:** Because Delete All Graphics After Addition was selected in the Add Graphics to Layer dialog, the graphic(s) you drew were automatically deleted.

**Resize, Reshape, and Move a Flux Line in a Flux Layer**

Use the following procedure to resize, reshape, or move a flux line in a flux layer.

1. From the ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
   
   A Start Editing dialog displays.

2. Select the flux layer from the list.

3. Click OK.

   The Create Features panel displays on the screen.

4. In the ArcMap Editor toolbar, click (Edit Tool).
5. Select the flux line you want to edit.

6. Use the tools in the ArcMap Editor toolbar to resize, reshape, and/or move the flux line as necessary.
   Refer to the ArcMap 10 documentation for details.

7. From the ArcMap Editor toolbar, select Editor>Stop Editing.

8. When prompted to save your changes, click Yes.

**Remove a Flux Line from a Flux Layer**

Use the following procedure to remove one or more flux lines from a flux layer.

1. In the ArcMap Table of contents, select the flux layer.

2. From the ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
   A Start Editing dialog displays.

3. Select the flux layer in the list.

4. Click OK.
   A Create Features panel displays.

5. Select the flux line(s) you want to delete.
   **Note:** To select multiple flux lines, click the first one and then, while holding down the Shift key, click each additional flux line.

6. In the SBAS Toolbar, select Edit>Remove Cells/Fluxes.
   A removal confirmation message box displays.
   **Note:** It is imperative that you use the SBAS Edit>Remove Cells/Fluxes command to remove flux lines, not the ArcMap Edit>Delete command. The SBAS command removes both the selected flux lines and their related values while the ArcMap command deletes only the line, which will result in an incorrect sediment budget calculation.

7. Click Yes.
   The selected flux line(s) are removed from the flux layer and the alternative, and the editing session is automatically closed.
8. If you’ve already saved the alternative in this ArcMap session, this procedure ends here.

However, if you haven’t yet saved the alternative in this ArcMap session and are prompted to save the alternative, click OK.

A Save Alternative dialog displays, prepopulated with the Alternative name and full path and file name.

9. Click Save Alternative.

An Overwrite message box displays.

10. Click Yes.

A Saved message box displays.

11. Click OK.

The data frame redisplays.

### Entering Littoral Cell and Flux Line Values

**Enter Littoral Cell Values**

1. In the ArcMap Table of Contents, select the littoral cell layer.

2. Using one of the ArcMap Select Features tools ( ), select the cell you want to edit.
3. In the SBAS Toolbar, select Edit> Edit Cell/Flux Values. 

A Cell Properties datasheet displays.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Value</th>
<th>Uncertainty</th>
<th>Locked</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOURCE Fluxes</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SBAS Layer 2.1</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td>SSAS Layer 1.2</td>
</tr>
<tr>
<td>SINK Fluxes</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SBAS Layer 2.2</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td>None</td>
</tr>
<tr>
<td>Flood</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td>N/A</td>
</tr>
<tr>
<td>Placement</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td>N/A</td>
</tr>
<tr>
<td>Removal</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td>N/A</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Variable</th>
<th>Value</th>
<th>Uncertainty</th>
<th>Percent</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Residual</td>
<td>0.00</td>
<td>0.00</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

4. Enter the appropriate values.

**Note:** There are various methods of obtaining these values (for example, the 3D Analyst, Spatial Analyst, and eGIS: Survey Toolbars).

5. Click Apply.

The value of the Residual variable is automatically calculated.

6. Click OK.

The dialog closes, the residual value is posted in the Residual field of the layer’s attribute table, and the littoral cell’s color changes according to the layer symbology in the ArcMap Table of Contents.

7. Repeat steps 2-6 for all other littoral cells.

### Entering Flux Line Values

1. In the ArcMap Table of Contents, select the flux line layer.

2. Using one of the ArcMap Select Features tools ( ), select the flux line you want to edit.
3. In the SBAS Toolbar, select Edit>Edit Cell/Flux Values.

   A Flux Properties datasheet displays.

4. Enter the appropriate values.

   **Note:** There are various methods of obtaining these values (for example, the 3D Analyst, Spatial Analyst, and eGIS: Survey Toolbars). Sediment transport rates produced from GENESIS model results can also be imported into GIS.

5. Click OK.

   The dialog closes.

6. Repeat steps 2-5 for all other flux lines.

---

### Identifying Littoral Cell Layer Confidence

At times, you may be uncertain about the values you entered for the littoral cells. Therefore, SBAS lets you identify a confidence level for each cell.

1. In the SBAS Toolbar, select Edit>Set Confidence.

2. From the Select Layer drop-down list box, select the littoral cell layer.

3. In the Select Record to Edit list, select the cell for which you want to set a confidence level.

4. In the New Value section, click the appropriate radio button (High, Medium, Low, or No Data).

5. Repeat steps 3-4 for each cell for which you want to set a confidence level.
6. Click Show Confidence Layer.

**Note:** You can also click Close and then, in the SBAS Toolbar, select Edit>Show Confidence to display the Confidence layer.

A Confidence layer is added to the ArcMap Table of Contents, and the cell outline(s) change according to the layer symbology.

---

**Creating a Macro Budget**

After a micro sediment budget has been developed using littoral cells and fluxes, a macro sediment budget can be created to represent it on a larger (regional) scale. The macro budget validates assumed quantities at the boundaries of a specified group of sediment budget cells.

To construct a macro budget, define the budget for all cells that are bounded by assumed quantities. The resulting macro budget should balance (that is, Residual=0). If it does not (Residual = non-zero), one or more of the assumed values must be revised.

**Note:** Once the macro budget has been created, the individual littoral cells can no longer be edited unless you first delete the macro budget cell (using the same procedure as for deleting a littoral cell). After making any necessary changes to the individual littoral cells, you must then create a new macro budget cell.
1. In the ArcMap Draw toolbar, click \( \text{(Polygon)} \) tool.

   **Note:** If the Draw toolbar isn’t displayed, from the Customize menu select Toolbars>Draw. If the \( \text{(Polygon)} \) tool isn’t displayed, click the \( \bullet \) button to the right of the selected shape tool and then, from the pop-up menu, click \( \square \) Polygon.

2. In the data frame, draw a polygon around the sediment budget area to be included in the macro budget.
**Note:** To make it easier to view the littoral cells and flow arrows inside the polygon, you can change the polygon fill and border color using the (Fill) and (Line) tools. In the following illustration, the polygon fill is set to No Color and the line to red.

3. In the SBAS Toolbar, select Budgets>Convert Graphics to SBAS Layer.

   A Convert Graphics to SBAS Layer dialog displays. The Select Alternative drop-down list box is automatically populated with the alternative name, and “Micro” is automatically selected as the Budget Layer Type.

4. In the Budget Layer Type section, make the following selections:

   - Select the Macro radio button.
   - In the Select Related Cell Layer drop-down list box, select the littoral cell layer.

5. In the Graphic Conversion Options section, select the Selected Graphics radio button.

   **Note:** Selecting the All Graphics radio button will delete *all graphics* not in layers/shapefiles (for example, arrows, labels, and other text), *not only* the graphics you just created and selected.
6. In the Graphic Conversion Options section, select Delete All Graphics in View after Conversion.

   **Note:** This option automatically deletes the graphic you drew, leaving only the macro budget cell.

7. To the right of the New Layer Name text box, click Browse.

   A Select New Layer Folder and Name dialog displays.

8. Browse to the appropriate directory.

9. In the File Name text box, type a name for the new layer.

10. Click Save.

   The Convert Graphics to SBAS Layer dialog redisplays.

11. Click Create New Layer.

   A message box displays, stating “Macro Budget Successfully Created.”

12. Click OK.

   The data frame redisplays. All graphics were converted into a macro budget layer, the new layer was added to the ArcMap Table of Contents, symbology was applied to the layer, and the layer was stored in the SBAS working directory. (See “Setting the SBAS Default Properties” on page 12.)
Saving an Alternative

While creating or editing layers, you may be prompted to save the alternative. However, you can use the following procedure at any point to save an alternative file.

1. In the SBAS Toolbar, select Alternative>Save Project Alternative.
   
   A Save Alternative dialog displays.

2. From the Select Alternative to Save drop-down list box, select the appropriate alternative.

3. In the File Path/Name text box, enter the full path and file name of the alternative, or click Browse, browse to the appropriate directory, enter a file name, and click Save.

4. Click Save Alternative.

5. If you haven’t saved the alternative before, the data frame redisplay, and this is the end of this procedure.
   
   However, if you’ve saved the alternative before and an Overwrite message box displays, stating “File of same name already exists. Overwrite?”, click Yes.

   **Note:** If you want to save the alternative under a different file name, click No, and then enter the full path and file name for the new alternative, or click Browse, browse to the appropriate directory, enter a file name, and click Save.
   
   A “Saved” message box displays, stating “Alternative has been saved.”

6. Click OK.
   
   The data frame redisplay.

Saving a New Alternative

At times, you may want to save your work to a new alternative to reflect different assumptions about sediment-transport rates and paths, and engineering activities within a budget, or to reflect different time periods.

Use the following procedure to save a new alternative.

1. In the SBAS Toolbar, select Alternative>New Alternative.
   
   An Enter Alternative Name dialog displays.
2. In the text box, type a name for the alternative.

3. Click OK.

   A New Alternative message box displays, stating, “Alternative successfully created.”

4. Click OK.

   The data frame redisplays.

### Copying an Alternative

Use the following procedure to make a copy of an alternative.

**Note:** The development team is currently verifying this functionality.

1. In the SBAS Toolbar, select Alternative>Copy Alternative.

   A Copy Alternative dialog displays.

2. From the Select Alternative to Copy drop-down list box, select the alternative that you want to copy.

   The Cell Layer Name and Flux Layer Name text boxes automatically populate with the associated layers.

3. Click Copy.

   An Enter Alternative Name dialog displays.

4. In the text box, type a name for the alternative.

5. Click OK.

   The data frame redisplays.

### Opening an Existing Alternative

Use the following procedure to load an existing alternative.

**Note:** The development team is currently verifying this functionality.
1. Open a saved ArcMap project file (.mxd).

   All sediment budget littoral cells and flux lines should be displayed.

2. In the SBAS Toolbar, select Alternative>Load Project Alternative.

   A Browse to Alternative dialog displays.

   **Note:** The associated alternative file must be loaded before you can add any more cell and flux values.

3. Browse to the location of the alternative file associated with the sediment budget layers.

   **Note:** If you don’t remember the associated alternative file name, the file path and name are tagged in the SBAS_File field of the layer's attribute table.

4. Click OK.

   The alternative is loaded.

   You can now edit the sediment budget in the SBAS environment.

### Loading an SBAS Layer

Use the following procedure to load an existing littoral cell or flux layer.

1. Open a saved ArcMap project file (.mxd).

   All sediment budget littoral cells and flux lines should be displayed.

2. In the SBAS Toolbar, select Budgets>Load SBAS Layer.

   An Add Data dialog displays.

3. Select the appropriate layer (.shp) file.

4. Click Add.

   The data frame redisplay with the selected layer added to the ArcMap Table of Contents and the data frame.
Using SBAS Standalone Files in SBAS for ArcGIS 10

Because SBAS Standalone is interoperable with ArcGIS, you can import shapefiles into SBAS Standalone and use them as a basemap when creating littoral cells and fluxes. This type of spatially enabled file assigns a coordinate system, so the sediment budget lies in the appropriate geographic space.

If a coordinate system has been assigned, sediment budgets you create using SBAS Standalone can easily be exported for use with ArcGIS/ArcMap 10. Use the following procedure to export an SBAS Standalone file for use in ArcGIS/ArcMap 10 with the SBAS Toolbar.

1. Open the SBAS Standalone file (*.sbs).

2. From the SBAS Standalone File menu select Export ArcView SBAS File.

   A Choose a Name for the SBAS Control File dialog displays.
3. In the File Name text box, type a name for the SBAS control file you’re exporting.

4. Click Save.

The SBAS Standalone file is exported with a .sbd extension. This file holds all of the alternative data, such as dV and placement values.

Two shapefiles (*.shp) are also created—one for the polygon littoral cells and the other for the polyline fluxes—and saved in the same location using the same name you provided for the .sbd file name (for example, Mobile Bar.sbd, Mobile Bar_cells.shp, and Mobile Bar_fluxes.shp).

5. Close SBAS Standalone.

6. Open ArcMap.

7. Create a new MXD file.

8. In the ArcMap Standard toolbar, click the ArcMap (Add Data) button.

   An Add Data dialog displays.

9. Locate and select the cell shape file exported in step 4.

10. Click Add.

11. The littoral cell layer is added to the ArcMap Table of Contents.

12. In the ArcMap Standard toolbar, click the ArcMap (Add Data) button again.

    An Add Data dialog displays.

13. Locate and select the flux shape file exported in step 4.

14. Click Add.

15. The flux layer is added to the ArcMap Table of Contents.
16. In the SBAS Toolbar, select Alternative>Load Project Alternative.

This is required in order to view the full detail of the alternative.

A message box displays, stating “Alternative: AlternativeName, from location has successfully loaded for layer: LayerName.”

17. Click OK.

18. View details of the alternative:

a. Select a layer in the Table of Contents.

b. Select a feature in the map display.

c. From the SBAS Toolbar, select Edit>Edit Cell/Flux Values.

A Cell Properties dialog displays.

19. Click OK.

The Cell Properties dialog closes, and a Save Alternative dialog displays, prompting you to resave the alternative.

20. Browse to the location where you want to save the alternative.

21. Click Save Alternative.

22. When you're done working with ArcMap, close the application.
Using SBAS Toolbar Files in SBAS Standalone

Use the following procedure to import a sediment budget (alternative and geometry) created in ArcMap/ArcGIS 10 with the SBAS Toolbar into SBAS Standalone.

1. In SBAS Standalone, select File>Import ArcView SBAS File.

   A Select the SBAS Control File dialog displays.

2. Locate and select the alternative (*.sbd file) that you previously created using SBAS Toolbar in ArcGIS/ArcMap 10.

3. Click Open.

   A Select the Cell Shape File dialog displays.

4. Locate and select the littoral cell shapefile (*.shp) for the alternative.
5. Click Open.

The Cell Shape File dialog redisplay.

6. Locate and select the flux shapefile (*.shp) for the alternative.

7. Click Open.

A Project Properties dialog displays.

8. Enter the project properties.
9. Click OK.

The sediment budget and alternative values are now available in SBAS Standalone.